Boost logo

Boost :

Subject: Re: [boost] Painting a bikeshed ...
From: alex (alexhighviz_at_[hidden])
Date: 2015-10-02 11:51:03


>> sorted_stratify (range, segment) ; // Sean's function
>> stratify (range, segment) ; // Marshall's function
>>
>
>I really like stratify.

Me too :) even though I think that term would require a more generic
interface than just allowing 3 strata, why not 2, 4 or n?
You could just supply n ranges and arrange the first stratum into the first
range, the second stratum into the second range, etc.

>I can see strata (and variations) becoming a term used in a number of
places.
>
>sorted_stratify() still doesn't seem quite right to me,
>[...]
>- wasn't stratify already sorting (in a course-grained way)
>- does it sort all 3 strata (and then isn't that just sort()?)
>
>midsort_stratify() ?
>stratify_subsort() ?
>

How about using the singular stratum to take away (reduce) that confusion

sort_stratum(range, segment); // Sean's function
stratify(ranges) ; // Marshall's function


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk