Boost logo

Boost :

Subject: Re: [boost] [fiber] ready for next review
From: Agustín K-ballo Bergé (kaballo86_at_[hidden])
Date: 2015-12-05 09:12:17

On 12/4/2015 11:48 AM, Agustín K-ballo Bergé wrote:
> On 12/4/2015 4:47 AM, Oliver Kowalke wrote:
>> 2015-12-03 22:21 GMT+01:00 Agustín K-ballo Bergé <kaballo86_at_[hidden]>:
>>> Yes, in the documentation.
>> documentation might need some updates - my announcement was primarly
>> focused to the source code
> Fair enough, I was misguided by the "ready for next review" subject as
> well as the announcement that requests from the review have been
> addressed. This is obviously not the case, but we can still make a lot
> of progress based on source code adjustments only.

The future error category uses plain "future" as its name. This is not
technically wrong, but given that it is used to identify the category
that an error belongs to, it would be better to choose a name that does
not clash with the standard library future error category. I would like
to suggest "boost::fiber", or "boost::fiber::future" if there might be
other error categories.

The implementation of `default_error_condition` makes use of some
alarming hard-coded magic constants in a switch statement. It appears
that every case in the switch is actually doing the same thing, which is
just what the overriden function already does. Since there is no mapping
of error values to default error conditions happening here, I would
suggest to drop the definition entirely.


Agustín K-ballo Bergé.-

Boost list run by bdawes at, gregod at, cpdaniel at, john at