Subject: Re: [boost] Alternative names to Boost.Fit
From: Michael Marcin (mike.marcin_at_[hidden])
Date: 2016-03-05 05:41:25
On 3/2/2016 12:46 PM, Paul A. Bristow wrote:
>> -----Original Message-----
>> From: Boost [mailto:boost-bounces_at_[hidden]] On Behalf Of Paul Fultz II
>> Sent: 02 March 2016 17:10
>> To: Boost devel archive
>> Cc: boost_at_[hidden]
>> Subject: Re: [boost] Alternative names to Boost.Fit
>> Alternatively, I wonder if its possible to use FunctionUtilities as the
>> library name, but use 'fu' as the namespace name.
> I don't think that there is any real need to make the Boost library name the same as the namespace name.
> I believe the library name should be description - clear not curt (and not cute either ;-).
> Nor is there any need to make the namespace name too short IMO.
> If code has lots of repeated references to the namespace (unlikely?)
> then a using funcutil::some_fun; or even using namespace funcutil; within local scope (not global scope of course).
> So I'd suggest Boost.FunctionUtilities and namespace funcutil;
> But it's your call (until you get shouted down ;-)
My first impressions if I saw the names:
boost::fit - no idea, something with forward iterators maybe?
boost::futils - file utilities?
boost::funcutil - deals with function or functional utilities?
My first impression of funcutil seems to be in line with the description
of the library from the OP so that'd be my vote of the names suggested
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk