Subject: Re: [boost] Alternative names to Boost.Fit
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2016-03-02 13:46:27
> -----Original Message-----
> From: Boost [mailto:boost-bounces_at_[hidden]] On Behalf Of Paul Fultz II
> Sent: 02 March 2016 17:10
> To: Boost devel archive
> Cc: boost_at_[hidden]
> Subject: Re: [boost] Alternative names to Boost.Fit
> Alternatively, I wonder if its possible to use FunctionUtilities as the
> library name, but use 'fu' as the namespace name.
I don't think that there is any real need to make the Boost library name the same as the namespace name.
I believe the library name should be description - clear not curt (and not cute either ;-).
Nor is there any need to make the namespace name too short IMO.
If code has lots of repeated references to the namespace (unlikely?)
then a using funcutil::some_fun; or even using namespace funcutil; within local scope (not global scope of course).
So I'd suggest Boost.FunctionUtilities and namespace funcutil;
But it's your call (until you get shouted down ;-)
--- Paul A. Bristow Prizet Farmhouse Kendal UK LA8 8AB +44 (0) 1539 561830
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk