Subject: Re: [boost] Alternative names to Boost.Fit
From: Robert Ramey (ramey_at_[hidden])
Date: 2016-03-05 09:50:25
On 3/2/16 6:48 AM, paul Fultz wrote:
> Hello All,
> Boost.Fit is a function utility library, however, the name currently doesn't
> have anything with this. I originally chose the name because it started with
> F(for function) and it was short and sounded nice. However, there could be
> some names(or abbreviations) that more adequately describe the library. Here
> are some alternatives that are short:
> - Boost.FP
> - Boost.FPL
> - Boost.Fun
> - Boost.FN
> Of course, I prefer the Boost.FN name. Names like Boost.FP or Boost.FPL could
> imply that it provides full functional constructs whereas Boost.Fit does not
> and is mainly focused on functions.
> Either way, this is something reviewers could consider as they review the
> library as I am not strongly tied to the name Boost.Fit.
> Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Personally, I'm not too crazy about abbreviations. And I'm not too
crazy about "cute" names either - spirit, hana, etc. So it was up to me
I'd live with "FunctionUtilities" or "FunctionObjects".
Shortening the name creates confusion, makes code less readable. Since
most of the library is defined inside the namespace, it doesn't really
add any typing. In those cases where the typing does get long, one can
at a (local) alias.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk