Subject: [boost] Alternative names to Boost.Fit
From: paul Fultz (pfultz2_at_[hidden])
Date: 2016-03-02 09:48:20
Boost.Fit is a function utility library, however, the name currently doesn't
have anything with this. I originally chose the name because it started with
F(for function) and it was short and sounded nice. However, there could be
some names(or abbreviations) that more adequately describe the library. Here
are some alternatives that are short:
Of course, I prefer the Boost.FN name. Names like Boost.FP or Boost.FPL could
imply that it provides full functional constructs whereas Boost.Fit does not
and is mainly focused on functions.
Either way, this is something reviewers could consider as they review the
library as I am not strongly tied to the name Boost.Fit.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk