Subject: Re: [boost] Alternative names to Boost.Fit
From: Paul Fultz II (pfultz2_at_[hidden])
Date: 2016-03-10 13:52:05
On Thursday, March 10, 2016 at 12:42:59 AM UTC-6, Vicente J. Botet Escriba
> Le 02/03/2016 15:48, paul Fultz a Ã©crit :
> > Hello All,
> > Boost.Fit is a function utility library, however, the name currently
> > have anything with this. I originally chose the name because it started
> > F(for function) and it was short and sounded nice. However, there could
> > some names(or abbreviations) that more adequately describe the library.
> > are some alternatives that are short:
> > - Boost.FP
> > - Boost.FPL
> > - Boost.Fun
> > - Boost.FN
> > Of course, I prefer the Boost.FN name. Names like Boost.FP or Boost.FPL
> > imply that it provides full functional constructs whereas Boost.Fit does
> > and is mainly focused on functions.
> > Either way, this is something reviewers could consider as they review
> > library as I am not strongly tied to the name Boost.Fit.
> Paul if the scope of the library is high order function I propose to
> rename it to Boost.HighOrderFunctions. We could use boost::hof as name
> space and boost/hof/ as folder.
The adaptors and decorators are HOFs, and the other functions are used to
when using HOFs, so it does make sense to name it Boost.HighOrderFunctions.
like this name.
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk