Subject: Re: [boost] Alternative names to Boost.Fit
From: Gavin Lambert (gavinl_at_[hidden])
Date: 2016-03-10 17:42:16
On 11/03/2016 07:52, Paul Fultz II wrote:
> On Thursday, March 10, 2016 at 12:42:59 AM UTC-6, Vicente J. Botet Escriba
>> Paul if the scope of the library is high order function I propose to
>> rename it to Boost.HighOrderFunctions. We could use boost::hof as name
>> space and boost/hof/ as folder.
> The adaptors and decorators are HOFs, and the other functions are used to
> help when using HOFs, so it does make sense to name it
>Boost.HighOrderFunctions. I like this name.
Or perhaps, HighOrderFunctionLibrary?
L __/  \
L \___ ___ ___]
(I regret nothing.)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk