Boost logo

Boost :

Subject: Re: [boost] Is there any interest in non-owning pointer-like types?
From: Gavin Lambert (gavinl_at_[hidden])
Date: 2017-02-09 23:59:58


On 10/02/2017 12:24, Joseph Thomson via Boost wrote:
> I initially read that as `caged_ptr`. I looked up the definition, and it
> does seem to have the right meaning. If such an uncommon word is
> undesirable, perhaps `obseved_ptr` or `watched_ptr` would be preferable
> (the "-ed" form of the veb matches `shared_ptr`).

At the risk of devolving into a bikeshed, I don't really like anything
that implies observing or watching unless it has the semantics of
weak_ptr and knows when it is no longer pointing to a valid object.

How about borrowed_ptr, unbound_ptr, irresponsible_ptr, unowned_ptr, or
not_null_ptr? (Though a shorter typedef probably should be encouraged
in practice or people would likely just stick with *.)


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk