Boost logo

Boost :

Subject: Re: [boost] [review] Review of PolyCollection starts today (May 3rd)
From: Joaquin M López Muñoz (joaquinlopezmunoz_at_[hidden])
Date: 2017-05-12 05:38:49

El 11/05/2017 a las 9:46, Hans Dembinski escribió:
> I tried to compile the tests on a Mac with Apple-clang 8.0.0. It worked after I manually specified "cxxflags=-std=c++11" in the b2 call. By the way, it would be great if b2 used the highest standard that is available by default.
>> It's weird because the Jamfile does have this flag already:
>> I guess the snapshot provided from the Incubator might be oldish and not
>> include that... I can't check right now because is not responding :-(
> It seems I got the right version, I checked out from github, not the incubator. My version of the Jamfile has these lines
> project
> : requirements
> <toolset>gcc:<cxxflags>-std=c++11
> <toolset>clang:<cxxflags>-std=c++11
> ;
> I am not a Boost.Build expert, but that looks ok to me. Nevertheless, when I run just ./b2 in the "tests" folder, it tries to compile but fails. When I run ./b2 cxxflags=-std=c++11, the tests compile fine.

I'm no Boost.Build expert either. A shot in the dark: maybe Apple-clang
has a different toolset than "regular" clang?

Joaquín M López Muñoz

Boost list run by bdawes at, gregod at, cpdaniel at, john at