Boost logo

Boost :

Subject: Re: [boost] [review] **NEXT WEEK** Review of Outcome (starts Fri-19-May)
From: Andrzej Krzemienski (akrzemi1_at_[hidden])
Date: 2017-05-15 12:25:43

2017-05-15 13:08 GMT+02:00 Niall Douglas via Boost <boost_at_[hidden]>:

> >> you get a C++ exception thrown of type monad_error(no_state).
> >
> > As a side note, it would be nice from my point of view if you eradicate
> > these last remaining references to 'monad' in the public interface and
> > make that outcome_error (resp. outcome_errc, outcome_category.)
> A lot of people grumble at having "monad" in the naming. I don't
> personally see the problem, it's just a name, and "basic_monad" is
> exactly what is it: a building block for a monad.
> I'll tell you what though, if two more people strongly feel that
> "basic_monad" and "monad_error" need to be renamed, I will do it. Please
> people do suggest a better alternative name though.

I strongly feel that name "monad" need to be renamed :)
Proposed alternatives:

   - `basic_monad` -> `outcome_base` or `basic_outcome`
   - `monad_error` -> `bad_outcome` or `outcome_error`


Boost list run by bdawes at, gregod at, cpdaniel at, john at