Subject: Re: [boost] [iterator] generator_iterator vs. function_input_iterator
From: Michel Morin (mimomorin_at_[hidden])
Date: 2017-08-31 16:16:50
Andrey Semashev wrote:
> There seems to be two nearly equivalent components in Boost.Iterator:
> generator_iterator (moved from Boost.Utility) and function_input_iterator.
`function_input_iterator`'s implementation looks better than that of
`generator_iterator`. However, the name of the former is not appealing.
"generate" is a standard word to Range enthusiasts -- it is used like
`generate(non_pure_func) | take(10)`.
Thus, I would like to deprecate `generator_iterator` first and then rename
`function_input_iterator` to `generator_iterator`.