Boost logo

Boost :

Subject: Re: [boost] [iterator] generator_iterator vs. function_input_iterator
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2017-08-31 16:52:35

On 08/31/17 19:16, Michel Morin via Boost wrote:
> Andrey Semashev wrote:
>> There seems to be two nearly equivalent components in Boost.Iterator:
>> generator_iterator (moved from Boost.Utility) and function_input_iterator.
> `function_input_iterator`'s implementation looks better than that of
> `generator_iterator`. However, the name of the former is not appealing.
> "generate" is a standard word to Range enthusiasts -- it is used like
> `generate(non_pure_func) | take(10)`.
> Thus, I would like to deprecate `generator_iterator` first and then rename
> `function_input_iterator` to `generator_iterator`.

Well, there is function_output_iterator also, I kind of like the
duality. I guess we could make generator_iterator an alias in C++11,
although I'm a bit worried if this could cause backward compatibility
for users if they upgrade from a release with the old generator_iterator.

Boost list run by bdawes at, gregod at, cpdaniel at, john at