Boost logo

Boost :

Subject: Re: [boost] [review][Fit] Review of Fit starts today : September 8 - September 17
From: Robert Ramey (ramey_at_[hidden])
Date: 2017-09-18 15:28:35

On 9/18/17 7:45 AM, paul via Boost wrote:

>> If I may suggest a name: I like description on github "function utility
>> library". So what about "Function Utilities", which is quite descriptive. On
>> the Boost library page it would be inserted next to "Function" and "Function
>> Types", which - ironically - seems quite "fit"ting.
> But if I use the FunctionUtilities, I would find calling
> `boost::function_utilities::pipable` or

at least as far as the namespace is concerned, users can and often do
declare namespace alias.

Users could also use a forwarding define - eg


So if the length of names is a concern it is addressable. Perhaps a
small section in the docs might suggest this. There's no issue with
name collision as it's it totally in the hands of the user who might
want to make his own code more readable.

Speaking of docs - a section FAQ might be a good place for all the
miscellaneous questions which arise in the review and subsequent
complaints. If you keep updating this, you'll find that you get no more
questions eventually.

FunctionUtilities. This seems to overlap with boost.callable library.

here are ones that occurred to me


Naming is always an issue and never satisfies everyone. Just do your best.

Robert Ramey

> I think HigherOrderFunctions is much more descriptive, and then I could use
> the namespace `hof` for short.
> Also, the word 'utility' is not very descriptive, and I would prefer to move
> away from using it. Boost.Utility contains random things in it that are
> unrelated, and I don't want this library to be described as a collection of
> random and unrelated functions.
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at