Subject: Re: [boost] [review][Fit] Review of Fit starts today : September 8 - September 17
From: paul (pfultz2_at_[hidden])
Date: 2017-09-18 14:45:18
On Mon, 2017-09-18 at 12:10 +0200, Hans Dembinski via Boost wrote:
> > On 15. Sep 2017, at 20:45, Robert Ramey via Boost <boost_at_[hidden]>
> > wrote:
> > I don't like names like Fit which give no helpful information.Â Â But I've
> > lost that battle before so I won't belabor this any more.
> I would like to join the chorus of people who don't like the name "Fit".
> Please - please - consider changing this.
> "Fit", what does it mean? Is it an acronym (perhaps for function interface
I was going for function utility library, which makes FUL, and I didnt like
that acronym(although it is the first three letters of my name) as it could
sound big and bloated. So I went with Fit, because it sounds much "healthier",
and I thought I could backronym it at some point.Â
> Was the library written in a "fit" of rage over the lack of proper tools? Is
> the library in particular good health, perhaps? The documentation does not
> tell us, but even if it would, a longer, more descriptive name would be
> In my personal professional context, a "fit" refers to code that adapts a
> statistical model to stochastic data by minimising a cost function, which
> somehow measures the closeness of the model and the data. Googling "c++ fit
> library" yields links to Boost.Fit, but the first other hits are related to
> such optimisation libraries (this is not because of my personal Google
> search bubble, I used a private browser session). This as another hint that
> the name "Fit" is misleading.
> If I may suggest a name: I like description on github "function utility
> library". So what about "Function Utilities", which is quite descriptive. On
> the Boost library page it would be inserted next to "Function" and "Function
> Types", which - ironically - seems quite "fit"ting.
But if I use the FunctionUtilities, I would find calling
`BOOST_FUNCTION_UTILITIES_STATIC_FUNCTION` to be just too long.Â
I think HigherOrderFunctions is much more descriptive, and then I could use
the namespace `hof` for short.
Also, the word 'utility' is not very descriptive, and I would prefer to move
away from using it. Boost.Utility contains random things in it that are
unrelated, and I don't want this library to be described as a collection of
random and unrelated functions.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk