Boost logo

Boost :

Subject: Re: [boost] [hash] Extract module from functional + std::hash_combine
From: Daniel James (dnljms_at_[hidden])
Date: 2017-12-20 14:52:07

On 19 December 2017 at 18:27, James E. King, III via Boost
<boost_at_[hidden]> wrote:
> container_hash
> chash
> pound (Boost.Pound) == Boost.# = hashtag = hash?

I like 'container_hash' as I think it's fairly clear, or perhaps
'unordered_hash'. I'm not keen on an abbreviation like 'chash', this
won't be typed a lot so clarity is more important than concision. As
this is a small support library, something like conan will often
install it for non-obvious reasons, so the name should be clear for
users who've never heard of it, so I don't like 'pound'. And from
other mails, I'm not keen on 'hash_core' as it suggests this is the
core for other libraries.

So for now, I'm thinking 'container_hash'. I'll wait a few more days
to allow for any other feedback.

Boost list run by bdawes at, gregod at, cpdaniel at, john at