Subject: Re: [boost] [hash] Extract module from functional + std::hash_combine
From: Peter Dimov (lists_at_[hidden])
Date: 2017-12-20 17:43:21
Daniel James wrote:
> > Given that the module defines the name boost::hash, I think that it
> > should be named 'hash'.
> 'boost::shared_ptr' is in 'smart_ptr' and it doesn't seem that confusing?
Yes but there isn't another library named "shared_ptr". If there were, then
it would be confusing.
What I meant was that the existence of boost::hash makes it awkward to use
'hash' as a module name for anything else, so we might as well use it for
the obvious thing.