Subject: Re: [boost] [hash] Extract module from functional + std::hash_combine
From: Daniel James (dnljms_at_[hidden])
Date: 2017-12-20 18:00:31
On 20 December 2017 at 17:43, Peter Dimov via Boost
> Daniel James wrote:
>> > Given that the module defines the name boost::hash, I think that it >
>> > should be named 'hash'.
>> 'boost::shared_ptr' is in 'smart_ptr' and it doesn't seem that confusing?
> Yes but there isn't another library named "shared_ptr". If there were, then
> it would be confusing.
> What I meant was that the existence of boost::hash makes it awkward to use
> 'hash' as a module name for anything else, so we might as well use it for
> the obvious thing.
If there is to be a better hash module, having an existing module
called 'hash' could make it less findable.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk