Boost logo

Boost :

Subject: Re: [boost] Reforming Boost.System and <system_error> round 2
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2018-01-16 18:58:36

On 01/16/18 21:22, Robert Ramey via Boost wrote:
> I don't think it's just for the sake of churn.  I think it's to improve
> program correctness by replacing ambiguous and opaque implicit behavior
> with unambiguous explicit behavior which is obviously correct on it's
> face without having to go look it in some documentation or source code
> somewhere else.

There's nothing ambuguous about the conversion operator, as it is
specified in the standard, and I find the syntax quite intuitive. You're
not improving correctness by replacing it with a regular method.
Instead, you're adding verbosity. Whether that is a good thing or not is
a matter of taste. Personally, I choose the shorter syntax in this case.

Also, simply replacing one construct with another doesn't "fix" the
code. On the opposite, it has the potential of breaking it.

Boost list run by bdawes at, gregod at, cpdaniel at, john at