Subject: Re: [boost] [atomic] (op)_and_test naming
From: Peter Dimov (lists_at_[hidden])
Date: 2018-01-24 14:55:05
Andrey Semashev wrote:
> On 01/24/18 16:09, Peter Dimov via Boost wrote:
> > Andrey Semashev wrote:
> >> My only ask is that the new names be concise, if possible.
> > The concisest I can come up with is sub_and_check_if_zero; anything else
> > either doesn't read correctly, or is still ambiguous.
> Maybe sub_and_test_zero then?
> So, do I understand correctly that, in your opinion, the current naming is
> confusing and should be changed?
If we assume that it's confusing - and if it weren't you wouldn't be
starting this thread - changing the return value from false to true would do
nothing to improve matters, in my opinion. There's nothing in the name that
indicates whether it returns true or false, so it'll just confuse the other
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk