Subject: Re: [boost] [atomic] (op)_and_test naming
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2018-01-24 14:30:11
On 01/24/18 16:09, Peter Dimov via Boost wrote:
> Andrey Semashev wrote:
>> My only ask is that the new names be concise, if possible.
> The concisest I can come up with is sub_and_check_if_zero; anything else
> either doesn't read correctly, or is still ambiguous.
Maybe sub_and_test_zero then?
So, do I understand correctly that, in your opinion, the current naming
is confusing and should be changed?