Subject: Re: [boost] [atomic] (op)_and_test naming
From: Gavin Lambert (gavinl_at_[hidden])
Date: 2018-01-25 22:38:39
On 26/01/2018 01:45, Andrey Semashev wrote:
> So would you prefer to keep the name and change the result?
That is my preference, yes. Though I know it could be problematic since
it's an effectively invisible breaking change. And while it's new,
there could still be some people using it in its current form before
1.67 is released.
Deprecating the current method and adding a new one with a new name is
the safer way to change the behaviour, but unfortunately "x_and_test"
already seems like the best name for this operation.
"add_test" could also work I guess (since existing methods like
"fetch_add" also lack a conjunction, I suppose one could argue that it
could be even more consistent that way). And it does get rid of the
slightly awkward "and_and_test", so it's not all bad.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk