Boost logo

Boost :

Subject: Re: [boost] [histogram] should some_axis::size() return unsigned or int?
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2018-11-29 13:13:05

> -----Original Message-----
> From: Boost [mailto:boost-bounces_at_[hidden]] On Behalf Of Hans Dembinski via Boost
> Sent: 29 November 2018 11:10
> To: Boost Devs
> Cc: Hans Dembinski; Jim Pivarski; Henry Schreiner
> Subject: [boost] [histogram] should some_axis::size() return unsigned or int?
> Dear community (especially the reviewers of boost.histogram),
> I am still working on finishing the library based on the excellent reviews I got in September. I cannot make up my mind about a
> specific detail of the library interface and would like to ask for your input.
> Every axis type is required to have a size() method, which returns the number of bins along that axis (without counting extra bins
> for under- and overflow). Should this method return `unsigned` or `int`?

<big snip>

you need a new name for signed axis size?

int axis_size()

perhaps ;-)


Paul A. Bristow
Prizet Farmhouse
Kendal UK LA8 8AB
+44 (0) 1539 561830

Boost list run by bdawes at, gregod at, cpdaniel at, john at