Boost logo

Boost :

Subject: Re: [boost] [histogram] should some_axis::size() return unsigned or int?
From: Hans Dembinski (hans.dembinski_at_[hidden])
Date: 2018-11-29 16:59:59

Dear Paul, dear Olaf,

> On 29. Nov 2018, at 14:13, Paul A. Bristow via Boost <boost_at_[hidden]> wrote:
> you need a new name for signed axis size?
> int axis_size()
> perhaps ;-)

both of you basically propose to have two similarly named "size" methods which return `unsigned` and `int` respectively. I really hope that you are kidding as indicated by the smileys in your messages.

What I really need is a custom integer type for the index which is signed but can be compared safely with both `int` and `unsigned`. I could create a new integer type with a struct or an enum class and then implement all the operators explicitly. It is a lot of work, though.

Boost list run by bdawes at, gregod at, cpdaniel at, john at