Boost logo

Boost :

Subject: Re: [boost] [histogram] should some_axis::size() return unsigned or int?
From: Hans Dembinski (hans.dembinski_at_[hidden])
Date: 2018-11-30 09:20:14

> On 30. Nov 2018, at 08:43, Olaf van der Spek <ml_at_[hidden]> wrote:
> On Thu, Nov 29, 2018 at 5:58 PM Hans Dembinski via Boost
> <boost_at_[hidden]> wrote:
>> Dear Paul, dear Olaf,
>>> On 29. Nov 2018, at 14:13, Paul A. Bristow via Boost <boost_at_[hidden]> wrote:
>>> you need a new name for signed axis size?
>>> int axis_size()
>>> perhaps ;-)
>> both of you basically propose to have two similarly named "size" methods which return `unsigned` and `int` respectively. I really hope that you are kidding as indicated by the smileys in your messages.
> Not really:

Ok, I see, thank you for the link. I am not sure if the proposal is the best solution for the show-case problem outlined in the proposal. My personal bias against having to similar "size" methods is high, since I feel that the high level interface now exposes a low-level problem, namely, how basic operators should work on signed and unsigned types.

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at