Subject: Re: [boost] [histogram] should some_axis::size() return unsigned or int?
From: Olaf van der Spek (ml_at_[hidden])
Date: 2018-11-30 07:43:55
On Thu, Nov 29, 2018 at 5:58 PM Hans Dembinski via Boost
> Dear Paul, dear Olaf,
> > On 29. Nov 2018, at 14:13, Paul A. Bristow via Boost <boost_at_[hidden]> wrote:
> > you need a new name for signed axis size?
> > int axis_size()
> > perhaps ;-)
> both of you basically propose to have two similarly named "size" methods which return `unsigned` and `int` respectively. I really hope that you are kidding as indicated by the smileys in your messages.
Not really: http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2018/p1227r0.html
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk