Boost logo

Boost :

From: Hans Dembinski (hans.dembinski_at_[hidden])
Date: 2019-08-12 08:41:22

Some more thoughts from a first glance at the library:

you list the user supplied operations. The method names should exactly correspond to the existing ones used by boost.iterator, see

compare vs. distance_to
equals vs. equal
next vs. increment
prev vs. decrement

The reason is that the old names were likely already "optimised" by previous reviews and you should make it easy for people to port existing code to iterator2. Switching from iterator to iterator2 should be as easy changing the included header for simple cases.

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at