Boost logo

Boost :

From: Deniz Bahadir (dbahadir_at_[hidden])
Date: 2019-08-20 08:41:00

Am 16.08.19 um 14:30 schrieb Deniz Bahadir:
> Am 15.08.19 um 22:18 schrieb Andrey Semashev via Boost:
>> On Thu, Aug 15, 2019 at 2:39 PM Deniz Bahadir via Boost
>> <boost_at_[hidden]> wrote:
>>>> As always, the release managers would appreciate it if you download
>>>> the candidate of your choice and give building it a try. Please report
>>>> both success and failure, and anything else that is noteworthy.
>>> I tried to build it on Ubuntu 18.04 with GCC 8 and C++17, with support
>>> for LibICU enabled, and got the following error:
>>> ```
>>>    error: Name clash for
>>> '<p/home/jenkins/workspace/Pipeline_Boost-1.71.0-rc2/gcc8/installed/opt/BENOCS/gcc8/lib/x86_64-linux-gnu>'
>>>    error:
>>>    error: Tried to build the target twice, with property sets having
>>>    error: these incompatible properties:
>>>    error:
>>>    error:     -  none
>>>    error:     -  <dll-path>/opt/BENOCS/gcc8/bin
>>> <linkflags>-L/opt/BENOCS/gcc8/lib/x86_64-linux-gnu <linkflags>-licudata
>>> <linkflags>-licui18n <linkflags>-licuuc
>>>    error:
>>>    error: Please make sure to have consistent requirements for these
>>>    error: properties everywhere in your project, especially for install
>>>    error: targets.
>>> ```
>>> Either I did something completely wrong or the configuration files of
>>> Boost.FileSystem are inconsistent regarding some compiler-flags!?
>> Boost.Filesystem Jamfile doesn't use the properties listed in the
>> error message and I don't see anything wrong with the Jamfile. My
>> guess is that there is some sort of a dependency from another library
>> that messes up these properties, but it is not clear from the message
>> what that other library is. Or maybe there's a different problem. A
>> Boost.Build magician is needed.
> I tested Boost 1.70.0 and 1.69.0 and realized that this error was
> introduced with Boost 1.70.0.
> Maybe that helps in nailing the source of error down?

Boost 1.71.0 is released now with this bug. And now I realized that I
was not the first to find that problem. There has been a bug-report in
Github already. [1]

Maybe this problem can be fixed before the next release?



Boost list run by bdawes at, gregod at, cpdaniel at, john at