Boost logo

Boost :

From: JeanHeyd Meneide (phdofthehouse_at_[hidden])
Date: 2019-11-28 14:18:48

> why was this library called fixed_string rather than static_string?

I like the name fixed because when I put it together with the static
keyword it seems like less of a mess:

     constexpr static static_vector...
     constexpr static fixed_vector...

I will say I like how the second one reads and static has the
connotation of lifetime implications that I'm not sure static_vector
or static_string actually do (they're not some sort of shared
global-like storage for a thing). I hope both get changed to "fixed",
as "static" is a nightmare of overloaded meaning, maybe with an alias
"template <...> using fixed_vector = static_vector<...>". (Or we just
come up with an even better short word, but I have no ideas for that!)

Still, existing practice is important...


Boost list run by bdawes at, gregod at, cpdaniel at, john at