Boost logo

Boost :

From: Hans Dembinski (hans.dembinski_at_[hidden])
Date: 2019-11-28 14:29:01

> On 28. Nov 2019, at 13:12, Vinnie Falco via Boost <boost_at_[hidden]> wrote:
> On Thu, Nov 28, 2019 at 12:56 AM Andrzej Krzemienski via Boost
> <boost_at_[hidden]> wrote:
>> why was this library called fixed_string?
> It was a mistake. It was originally static_string (it came from
> beast[1]) but someone suggested changing it and I listened. Oh well.

We already discussed the name a bit. At the danger of getting into bike-shedding (but names are important):

Mateusz made the proposal "fixed_capacity_string", which is long but more precise than either static_string or fixed_string.

I don't find the long name problematic, because I assume that this type wont often appear in interfaces, but rather somewhere deep in the implementation.

Yet another idea:


Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at