Boost logo

Boost :

From: Julien Blanc (julien.blanc_at_[hidden])
Date: 2019-11-28 18:14:19

Le jeudi 28 novembre 2019 à 15:29 +0100, Hans Dembinski via Boost a
écrit :
> > We already discussed the name a bit. At the danger of getting into
> bike-shedding (but names are important):
> Mateusz made the proposal "fixed_capacity_string", which is long but
> more precise than either static_string or fixed_string.

It is. And i expect users who wish a shorter name to define fc_string
as a non ambiguous alias.

> I don't find the long name problematic, because I assume that this
> type wont often appear in interfaces, but rather somewhere deep in
> the implementation.


> Yet another idea:
> array_string

This may mislead the reader (at least some non native english ones)
into thinking it is an array of string. Array also misses the
distinction between size / capacity, thus it does not look like a so
good idea (there are places where a fixed_size_string could be useful).

static_string has the advantage of consistency with static_vector. But
static_vector is not a very good name itself.



Boost list run by bdawes at, gregod at, cpdaniel at, john at