Boost logo

Boost :

From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2020-05-31 21:05:22


As some of you may know, C++20 added new waiting/notifying operations to
std::atomic: wait, notify_one and notify_all. These operations are not
address-free, i.e. their implementation is allowed to use process-local
addresses of the atomics as keys. In particular, it means you can't use
them for inter-process communication.

In Boost.Atomic I intend to provide address-free variants as well, where
possible, and I'm thinking about the naming scheme for them. Currently,
I'm using the "_address_free" suffix, so we have wait_address_free,
notify_one_address_free and notify_all_address_free. The "address-free"
term comes from the C++ standard, but the resulting names seem a bit
long. Maybe there are better suggestions?


Boost list run by bdawes at, gregod at, cpdaniel at, john at