Boost logo

Boost :

From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2020-06-01 14:17:21

On 2020-06-01 15:05, Phil Endecott via Boost wrote:
>> In Boost.Atomic I intend to provide address-free variants as well,
>> where possible, and I'm thinking about the naming scheme for them.
>> Currently, I'm using the "_address_free" suffix, so we have
>> wait_address_free, notify_one_address_free and
>> notify_all_address_free. The "address-free" term comes from the C++
>> standard, but the resulting names seem a bit long. Maybe there are
>> better suggestions?
> boost::interprocess::atomic.

That name cannot be used in Boost.Atomic as it is reserved for

Atomics that are lock-free can already be used for inter-process
communication, so a hypothetical boost::interprocess::atomic would
largely duplicate boost::atomic. However, I'm open to the idea, if it is
significantly different from boost::atomic.

Boost list run by bdawes at, gregod at, cpdaniel at, john at