Boost logo

Boost :

From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2021-06-03 15:25:55

On 6/3/21 5:06 PM, Deniz Bahadir via Boost wrote:
> I totally support what Mike just wrote.
> I would just choose the latest available CMake version (3.20) as the
> starting point and see how it goes from there.

I have to say that if we choose the latest CMake version as the minimum,
this would be unmaintainable for me. I won't be installing non-standard
CMake versions on my development machines. This would also be
problematic for CI.

I think, there doesn't have to be a single minimum version to mandate.
This is a question each library maintainer can answer himself. I, for
one, don't need anything above 3.5 in the libraries I currently
maintain, possibly even less than that. If I had to pick a reasonable
threshold version for my libraries, based on the CMake versions
available in various distros that I listed earlier, it seems somewhere
around 3.9-3.10 would still maintain reasonable compatibility while
being relatively recent.

But I think the real question Peter is asking is what minimum version
Boost superproject and common CMake scripts should require. My
preference would be as low as possible, definitely not the latest, as
suggested by some. But I don't know about the superproject or CMake
enough to require anything; I don't know what CMake features would be
important there. It looks like Peter, as the main (only?) maintainer of
those scripts, has the best knowledge to make that decision.

Boost list run by bdawes at, gregod at, cpdaniel at, john at