|
Boost : |
From: Niall Douglas (s_sourceforge_at_[hidden])
Date: 2023-10-03 07:09:24
On 03/10/2023 06:52, Klemens Morgenstern wrote:
> The solution Niall opted for is eager & lazy. I don't like adjectives
> as class names (similarly I don't like asio::awaitable) because that's
> a property of a thing. So imo they should be concepts or traits (e.g.
> is_eager), which is the case with async::awaitable.
That's not quite accurate. In Outcome I used:
`boost::outcome::awaitables::eager<T>`
`boost::outcome::awaitables::lazy<T>`
The enclosing namespace `awaitables` I think is rather important to the
naming choices of "eager" and "lazy".
Niall
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk