Boost logo

Ublas :

From: Toon Knapen (toon.knapen_at_[hidden])
Date: 2006-04-24 07:36:31

Neal Becker wrote:

> It should be called scalar_t.

The real_type is not the scalar_type (or scalar_t) AFAICT. A
ublas::vector< std::complex< double > > 's real_type is 'double' while
the scalar_type which you are looking for IIUC can be found using
value_type which is equal to 'std::complex< double >'