Boost logo

Ublas :

From: Kresimir Fresl (fresl_at_[hidden])
Date: 2007-03-18 12:09:57

Karl Meerbergen wrote:

> What I should have said: size1() and size2() of the ublas::matrix, not
> functor_type. size1() and size2() do no longer exist in functor_type, so
> that is why they had to be changed into size_m.
> What I meant is that we can implement the bindings using size1() and
> size() of ublas::matrix(), which makes the bindings independent of ublas
> internals.

Sorry, I misunderstood you.

And I must admit that I do not remember why original design used that
somewhat roundabout way with functor_type::size2(). As far as I can
remember, it was Joerg Walter's suggestion (and he had some reasons :o).