Boost logo

Ublas :

From: Franz Müller (Franzl.Mueller_at_[hidden])
Date: 2007-07-24 17:41:06

Thanks a lot, you saved my day!

It indeed was the wrong order of libraries. (The extern "C" was just there by mistake, since I couldn't figure out what was wrong I played around).

In case someone else has the problem:
g++ ... mmtest.cpp -lf77blas -lcblas -ltstatlas -lptcblas -lptf77blas -llapack -latlas
worked for me. It's important that -latlas is on the very end.

I didn't know that the order of the libraries actually does make a difference...

Thanks again,

> Franz Müller schrieb:
> > Dear mailing list,
> >
> > I tried to compile a very simple example using uBlas and the ATLAS
> bindings, see below.
> >
> > I compiled it on Linux using the command (directories are correct)
> >
> > g++ -DNDEBUG -O2 -I /usr/boost/include/boost-1_34/ -I /usr/ATLAS/include
> -L /usr/boost/lib -L /usr/ATLAS/lib -latlas -lf77blas -lcblas -latlas
> -llapack mmtest.cpp
> >
> AFAIR there are two possible problems:
> the correct underscore _dgemm or __dgemm or dgemm_ (should only apply
> to fortran libs)
> the order of "-l" options (applies to statically linked libraries)
> (try to put all -l behind mmtest.cpp)
> Additionally the extern "C" { ... } should not be necessary if you
> include the cblas-header.
> Gunter
> _______________________________________________
> ublas mailing list
> ublas_at_[hidden]

GMX FreeMail: 1 GB Postfach, 5 E-Mail-Adressen, 10 Free SMS.
Alle Infos und kostenlose Anmeldung: