[Boost-bugs] [Boost C++ Libraries] #3770: Can't find usable endpoint to localhost/

Subject: [Boost-bugs] [Boost C++ Libraries] #3770: Can't find usable endpoint to localhost/
From: Boost C++ Libraries (noreply_at_[hidden])
Date: 2009-12-15 14:42:13

#3770: Can't find usable endpoint to localhost/
 Reporter: Collin Dauphinee <dauphic@…> | Owner: chris_kohlhoff
     Type: Bugs | Status: new
Milestone: Boost 1.42.0 | Component: asio
  Version: Boost 1.41.0 | Severity: Problem
 Keywords: |
 On my 32-bit Vista machine at work, I have code using Boost.ASIO that is
 unable to find a usable endpoint to localhost or The code I'm
 using is a copy of the Synchronous TCP Client code with the server changed
 to "localhost" or "" (I've tried a few different addresses) and
 the service name change to "9733". I also have a server accepting
 connections on port 9733 running on the same machine.

 When I attempt to resolve or localhost, I get one endpoint that
 gives a 'Host not known' error when I try to connect. I think this might
 be a dummy endpoint, as I get one of these no matter what the host name
 is? I've also tried all combinations of flags with the query.

 When I attempt to resolve the machine's name, I get three endpoints. The
 first is the 'Host not known' one. The next two, I believe, are going
 outside of my network and coming back, as my router seems to be rejecting
 their connections.

 My home computer uses Boost 1.38 and can make connections to localhost no
 problem, though it's using Windows XP.
 My work computer also has another test server/client using a different
 version of Boost; I believe it was one of the first releases, as it uses
 boost::asio::error_code rather than boost::system::error_code. This
 program can find a valid endpoint to both localhost and
 My work computer has yet another server/client that uses winsock, and the
 client can connect to the server running on the same machine via
 or localhost without any problems. This leads me to believe there's a
 problem with Boost 1.41's ASIO.

 I did notice a similar ticket marked as resolved because the problem is
 outside of ASIO's scope, but neither of the reasons given seem to be the
 case here. And again, an older version of ASIO and winsock both work, but
 1.41's version of ASIO does not.

 I'm sorry that I can't give more helpful information.

Ticket URL: <https://svn.boost.org/trac/boost/ticket/3770>
Boost C++ Libraries <http://www.boost.org/>
Boost provides free peer-reviewed portable C++ source libraries.

This archive was generated by hypermail 2.1.7 : 2017-02-16 18:50:02 UTC