From: Dan Gohman (gohmandj_at_[hidden])
Date: 2002-06-11 15:14:32
On Mon, Jun 10, 2002 at 02:20:03PM -0500, Rene Rivera wrote:
> On 2002-06-10 at 01:54 PM, gohmandj_at_[hidden] (Dan Gohman) wrote:
> >I'm thinking about suggesting something like this:
> > feature integer-model : unspecified ilp32 lp64 ; # add others as needed
> Good name! It's specific enough that other options that also affect the ABI
> on other platforms don't collide :-)
> Question, though... What does "ilp" and "lp" stand for?
i, l, and p stand for int, long, and pointer. It really isn't that useful
to be able to specify the size of `int' or `long' (as long as
<boost/cstdint.hpp> works :-)), but being able to specify the pointer
size is very useful.
Maybe the feature would be more appropriately be named `pointer-size'.
# This feature specifies the pointer size in bits.
feature pointer-size : unspecified 16 32 64 ;
Optionally, `default' might look better than `unspecified' in everyone's
build directories. How does that sound?
-- Dan Gohman gohmandj_at_[hidden]
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk