From: Vladimir Prus (ghost_at_[hidden])
Date: 2002-07-05 10:23:34
David Abrahams wrote:
> \From: "Vladimir Prus" <ghost_at_[hidden]>
> > It was agreed that "subproject" is a better name than the current
> > "subinclude", but now I realize that semantic of "subproject" is not
> > (I'm actually just trying to document existing functionality, and this
> > discover some more problems)
> > The parent for each project is now found automatically, using crawl-up.
> > what should "subproject" do:
> > 1. Just load the specified jamfile, so that it could declare some
> > proejct-ids. In this case, the "subproject" name is completely wrong --
> > does not affect project relationship.
> > 2. Cause the specified project to be build whenever current project is
> It seems like "subproject" is wrong in either case.
Why is it wrong in the second case and what other name do you suggest?
> > The latter option is better for me... and it is the current behaviour
> > (although untested).
> > Would we need a separate functionality for the first option?
> I don't think so. Why bother explicitly loading a (sub)project if you don't
> want its components to be built?
To allow them to define their project-ids. However, I agree that we need no
bother with it now.
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk