From: Vladimir Prus (ghost_at_[hidden])
Date: 2002-07-05 10:34:32
David Abrahams wrote:
> From: "Vladimir Prus" <ghost_at_[hidden]>
> > > I think the right thing is to just fold all that functionality into
> > > "expand". I was just reluctant to re-write all those tests which do the
> > > expansion without the defaults, because I think they're valuable for
> > > purposes of checking that the implementation is working.
> > I understand you.
> > > Maybe you can help resolve this tension somehow...
> > Can't we just rename current 'expand' to something else and current
> > 'expand-with-default' to 'expand'. This way you won't have to rewrite any
> > tests.
> Perfect. A small issue only: the current "expand" should be a local rule,
> but I guess you can explicitly import it into the test-space.
Yea. Who's gonna make this change? (We can just enter an issue and do it
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk