Boost logo

Boost-Build :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-07-05 10:26:47

From: "Vladimir Prus" <ghost_at_[hidden]>

> > I think the right thing is to just fold all that functionality into
> > "expand". I was just reluctant to re-write all those tests which do the
> > expansion without the defaults, because I think they're valuable for
> > purposes of checking that the implementation is working.
> I understand you.
> > Maybe you can help resolve this tension somehow...
> Can't we just rename current 'expand' to something else and current
> 'expand-with-default' to 'expand'. This way you won't have to rewrite any
> tests.

Perfect. A small issue only: the current "expand" should be a local rule,
but I guess you can explicitly import it into the test-space.



Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at