Boost logo

Boost-Build :

From: David Abrahams (dave_at_[hidden])
Date: 2003-01-16 08:01:48

Ulrich Eckhardt <uli_at_[hidden]> writes:

> On Wednesday 15 January 2003 15:49, you wrote:
>> At 04:25 AM 1/15/2003, Steven Kirk wrote:
>> >windows. Judging by the naming convention used by the other current boost
>> >libraries, shouldn't this library be called "libboost_filesystem.lib"?
>> Yes, I guess. I'll add it to the do list.
> Isn't there a big flaw in that naming-convention ? It means I can't install a
> version compiled for different compilers due to their differing ABIs.
> Therefore, I'd rather go for
> libboost_<name>_<ABI-tag>-version.lib
> 'name' being 'filesystem' in this case and 'ABI-tag' an identifier for the
> compiler, possibly including the stdlib. (note: STLport already uses such a
> scheme, I'd prefer just stealing their ABI-tags if there are no good reasons
> to do otherwise).

You're probably right. We don't have a system to do that right now,
but it's probably a pretty easy change.

David Abrahams
dave_at_[hidden] *
Boost support, enhancements, training, and commercial distribution

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at