From: Rene Rivera (grafik666_at_[hidden])
Date: 2003-01-16 10:45:48
[2003-01-16] David Abrahams wrote:
>Ulrich Eckhardt <uli_at_[hidden]> writes:
>> On Wednesday 15 January 2003 15:49, you wrote:
>>> At 04:25 AM 1/15/2003, Steven Kirk wrote:
>>> >windows. Judging by the naming convention used by the other current
>>> >libraries, shouldn't this library be called "libboost_filesystem.lib"?
>>> Yes, I guess. I'll add it to the do list.
>> Isn't there a big flaw in that naming-convention ? It means I can't
>> version compiled for different compilers due to their differing ABIs.
>> Therefore, I'd rather go for
>> 'name' being 'filesystem' in this case and 'ABI-tag' an identifier for
>> compiler, possibly including the stdlib. (note: STLport already uses such
>> scheme, I'd prefer just stealing their ABI-tags if there are no good
>> to do otherwise).
>You're probably right. We don't have a system to do that right now,
>but it's probably a pretty easy change.
Not totally right... It should be:
Putting the version at the end is somewhat standard. And in my current case
of OpenBSD required.
I could easily do this in BBV1:
The "boost_<name>" part is up to the library authors. If no one has
-- grafik - Don't Assume Anything
-- rrivera_at_[hidden] - grafik_at_[hidden]
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk