Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2003-03-13 05:51:01

Hi Kirill,

klapshin wrote:
> I am having few problems on CygWin with latest boost CVS snapshot.
> I am building project with a number of dlls, and I need a way to run
> program easily. I tried hardcode-dll-paths=true, but it does not
> seem to work on CygWin, so I decided to use stage rule to copy all
> binaries in top\bin folder.

It's a pity if we can't make hardcode-dll-paths=true to work on Cygwin. It's
so convenient!

> First problem was that CP variable is empty and copying of the dlls
> failed. I worked around this one with bjam -sCP=cp.

There must be something wrong there. If you look at "common.jam" you'll
see that "CP" is always set to some value. Are you sure you have up-to-date
bjam binary? A bug which could have causes this problem was fixed recently

> BTW: was not it supposed to be relinked rather then copied?

Yes, it used to do copying, but was switched to relinking. I though this
question might recur from time to time, so I've quickly set up a FAQ page on
the Boost Wiki. Please see

It contains a link to a message with a big of motivation.

> Next problem was with exe file. Stage failed with following errors:
> -----------------
> /cygdrive/c/work/boost1/tools/build/new/stage.jam:97: in
> object(stage-exe-gener
> tor)
> *** argument error
> * rule object(file-target)@174.depends ( d + )
> * called with: ( )
> * missing argument d

I believe I've fixed this. Could you please try again? Note that you'll see
a verbose warning about "unsused source target". Please ignore this
for now. We'll fix it a little bit later.

> One more thing. Suppose I want to install all dlls to bin subfolder
> of project root. I tried to define path-constant in project-root,
> and then in one of subprojects apply stage on target and supply path
> from that path-constant. I end up with dll being copied into bin
> subfolder of subproject, rather then root. Is it expected behavior?
> My workaround was to put all stage rules in root Jamfile.

I cannot reproduce this problem. Please unpack the attached archive,
cd to "d" and run "bjam dist" there. Top-level directory "dist" will be

If you still have problems, could you create a simple test case for me to

 --------------Boundary-00=_1TOOPZ5L07J6EIVAHEA6 Content-Type: application/x-tgz;
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="sss.tar.gz"

[Attachment content not displayed.] --------------Boundary-00=_1TOOPZ5L07J6EIVAHEA6--

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at