Boost logo

Boost-Build :

From: Rene Rivera (grafik666_at_[hidden])
Date: 2003-10-13 12:11:56


[2003-10-13] Pedro Ferreira wrote:

>Hi,
>
>I've attached my first stab at implementating numbers.increment.
>
>I still have a few doubs, though:
>
>- I called it NUMBERS_INCREMENT and placed it in "builtins.c". Please
advise
>on better name/location.
>- Should this be inside a module (Is it possible to do it inside bjam
>itself)?
>
>In my installation, I've replaced the body of numbers.increment with a
>single call to NUMBERS_INCREMENT. The speed-up factor was about 40.

Since we are going down this path here are some comments...

* Instead of having possibly many math operation builtins it would be better
to have a single builting to do simple math:

rule CALC ( expression + )...

For now just supporting a "+" would be fine, example:

local v = [ CALC 1 + 2 ] ;

* Stick to using standard C functions, i.e. don't use _itoa as it won't be
generaly available. Replacing it with a sprintf would be best .

-- grafik - Don't Assume Anything
-- rrivera (at) acm.org - grafik (at) redshift-software.com
-- 102708583 (at) icq

 


Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk