From: David Abrahams (dave_at_[hidden])
Date: 2004-10-06 07:20:44
Vladimir Prus <ghost_at_[hidden]> writes:
> David Abrahams wrote:
>> Vladimir Prus <ghost_at_[hidden]> writes:
>> > exe foo : foo.cpp : <relevant-feature>none ;
>> I am not fond of the name "relevant-feature." I suggest:
>> exe foo : foo.cpp : <build-subdirectory>none
> 1. The build directory is still used, in my proposal. That is, targets are
> placed in "bin", not in ".".
That's why it says "subdirectory"
> 2. How do we specify that we want some specific property in path. E.g.
> exe foo : foo.cpp : <relevant-feature>doc-format ;
> The <build-subdirectory> does not sound good in that context.
I'm warming to relevant-feature a bit, but it's still obtuse. I know
I came up with the term, but I never expected it to be in a prominent
place in the system's UI.
>> That said, is this really something we want to set on a
>> target-by-target basis?
> Sometimes so, sometimes not. One use case is files produced by a
> parser generator -- if we add the generated files to CVS, we want
> Boost.Build to use "bin" path. If we don't add them to CVS, we want
> "bin/gcc/whatever" path.
> As I've mentioned, with <relevant-feature> it's still possible do
> this this on per-generator basic -- the generator will add
> <relevant-feature> properties just before creating the dependency
-- Dave Abrahams Boost Consulting http://www.boost-consulting.com
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk