Boost logo

Boost-Build :

From: Rene Rivera (grafik.list_at_[hidden])
Date: 2004-11-10 17:16:29

Van Nguyen wrote:

> I'm trying to include a new toolset called ccsimpc for bjam. The link
> procedure requires a few steps. In my ccsimpc.jam file, I have:
> [...]
> actions link bind LIBRARIES
> {
> "$(CONFIG_COMMAND)" -r -nostdlib "$(>)" -o partialImage.o
> rm -f ctdt.c 2> /dev/null
> nmsimpc -g partialImage.o | wtxtcl
> C:/Tornado2.2/host/src/hutils/munch.tcl -c simpc > ctdt.c
> "$(CONFIG_COMMAND)" -c -fdollars-in-identifiers -g -mpentium -ansi
> -fno-builtin -fno-defer-pop ctdt.c -o ctdt.o
> "$(CONFIG_COMMAND)" -r -nostdlib -Wl,--force-stabs-reloc
> partialImage.o ctdt.o -o "$(<)"
> }
> [...]

Looks OK. But why do you have both Unix (the /dev/null) and Windows
(C:/...) syntax in the same action?

> I couldn't find the right syntax for executing multiple commands.
> Also, the weird thing is even if I commented out other commands, I
> still got the same error. It only worked if I keep 1 line and delete
> the rest of the commands.

Make sure the EOLs are correct for the shell that's executing the
commands. If you mix them up it might think the whole thing is a single

> Another question, how do I get the path to my bin/ccsimpc/debug
> directory from here? I can't use $(<) as it's bin/ccsimpc/debug/test.out.


See for useful things
like that :-)

-- Grafik - Don't Assume Anything
-- Redshift Software, Inc. -
-- rrivera/ - grafik/ - 102708583/icq

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at