Boost logo

Boost-Build :

From: Van Nguyen (nguyenhaivan78_at_[hidden])
Date: 2004-11-11 18:40:59

> > I couldn't find the right syntax for executing multiple commands.
> > Also, the weird thing is even if I commented out other commands, I
> > still got the same error. It only worked if I keep 1 line and
> > the rest of the commands.
> Make sure the EOLs are correct for the shell that's executing the
> commands. If you mix them up it might think the whole thing is a
> line.

Thanks! That was exactly the problem. I had to write up a small perl
script and let the actions link call it.

Now I'm having problems trying to generate .out file instead of .exe
file. I kinda hacked it a little bit with builtin.jam where I added:

declare-type NT CYGWIN : OUT : out : : ;
declare-type : OUT : : : ;
rule __init__ ( name : project : sources * : requirements * :
default-build * : usage-requirements * )
if ccsimpc in [ modules.peek : ARGV ]
typed-target.__init__ $(name) : $(project) : OUT
: $(sources) : $(requirements) : $(default-build)
: $(usage-requirements) ;
} else {
typed-target.__init__ $(name) : $(project) : EXE
: $(sources) : $(requirements) : $(default-build)
: $(usage-requirements) ;

But this will break things horribly if I build my apps with bjam using
ccsimpc and one or more other toolsets (e.g. bjam gcc ccsimpc)

I'm sure there's a much better way to do this. If you could point me
to a document regarding to this issue, I'd greatly appreciate that.

Also, since a new toolset is added, here's a list of files I think
that need to be updated accordingly.


Please correct me if I missed out something or had too many.

Thanks again, very much.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at